วันพุธที่ 27 มิถุนายน พ.ศ. 2561

ทดสอบ ถอดชุด Raid เก็บไว้ แล้วนำเครื่องไปใช้งานอื่นพร้อม Disk ชุดใหม่ เสร็จแล้วนำ Raid ชุดเดิมกลับมาใส่อีกครั้งจะเป็นอย่างไรบ้าง

ปัญหาได้รับแจ้งจากเพื่อนมาว่า Server พังแต่ Disk ยังใช้งานได้อยู่ ถ้านำ Disk ชุดนี้ไปเสียบกับเครื่องอื่น รุ่นเดียวกันจะสามารถทำงานต่อได้เลยหรือไม่ (เบื้องต้นต้องการแค่ข้อมูลบางส่วนใน Raid ชุดดังกล่าว)

เบื้องต้อนพอดีว่ามีเครื่อง Server ว่างอยู่ พร้อม Disk 2 ชุด (4 ลูก) เลยตั้ง lab ทดสอบตามขั้นตอนนี้ครับ

 

  1. ใส่ Disk ชุดที่ 1 (300GB 2 ลูก) เข้าไปที่เครื่อง แล้วทำการตั้งค่า Raid 1 ให้เรียบร้อย เสร็จแล้วทำการติดตั้ง Windows จนสามารถ Boot เข้า Windows ได้
  2. ทำการถอด Disk ชุดที่ 1 ออก 
  3. ใส่ Disk ชุดที่ 2 (146GB 2ลูก) เข้าไปที่เครื่อง แล้วทำการตั้งค่า Raid 1 ให้เรียบร้อย เสร็จแล้วทำการติดตั้ง Windows จนสามารถ Boot เข้า Windows ได้
  4. ทำการถอด Disk ชุดที่ 2 ออก
  5. ใส่ Disk ชุดที่ 1 กลับเข้าไป 

 เปิดเครื่องตามปกติ

ระบบแจ้งเตือนว่ามีการนำ Disk ชุดเก่า นำกลับมาเสียบกับเครื่อง แจ้งให้ทำการกด ปุ่ม C เพื่อ Load Config

ระบบแจ้งว่าให้กดปุ่ม Y เพื่อเข้าทำการตั้งค่าระบบ

เข้า Raid Controller


แจ้ง Import Config เดิม

ตรวจสอบ Config ที่มี แล้วกด Preview

 ระบบจะแสดง ข้อมูล Raid ชุดที่นำกลับมาใส่ ทำการตรวจสอบแล้วทำการกด Import

 เมื่อ Import เรียบร้อย Raid จะแสดงข้อมูลที่เคยตั้งค่าไว้

ตรวจสอบเล็กน้อย

ทดสอบเข้า BIOS พบว่ามีแจ้ง Error เกี่ยวกับ DISK ไม่ได้ทำอะไรเพิ่มเติม 

ทดสอบ Boot เครื่อง พบว่าสามารถ Boot ได้ตามปกติ

สามารถเข้า Windows ได้ตามปกติ


จากการทดสอบพบว่า Raid Config น่าจะมีเก็บไว้ที่ Disk ด้วย พอเปิดมาระบบจะทำการตรวจสอบเบื้องต้นและให้ Import Config ดังกล่าวเข้าไปที่ Raid Controller เพื่อให้สามารถทำงานต่อได้


อ้างอิง Concept จากกระทู้นี้นะครับ
https://d.thaihosttalk.com/t/raid-card-dell/22355

ไม่มีความคิดเห็น:

แสดงความคิดเห็น